LOVD 2.0

Welcome to the LOVD 2.0 bug tracking system. Please note that this bug tracking system is not for LOVD 3.0!

If you have any issues, please read the documentation and Frequently Asked Questions.
Please note that you need to register before you can submit bugs or feature requests.

Information By default, all closed tasks are hidden from view.
Click here to see all tasks.

Tasklist

FS#23 - showmaxdbid displays wrong gene

Attached to Project: LOVD 2.0
Opened by Raymond Dalgleish (rwmd) - Friday, 04 April 2008, 17:40 GMT+2
Last edited by Ivo F.A.C. Fokkema (ifokkema) - Monday, 17 November 2008, 10:07 GMT+2
Task Type Bug Report
Category Modules → ShowMaxDBID
Status Closed
Assigned To Ivo F.A.C. Fokkema (ifokkema)
Operating System All
Severity Medium
Priority Normal
Reported Version 2.0-05
Due in Version 2.0-14
Due Date 2008-11-28
Percent Complete 100%
Votes 0
Private No

Details

My database holds data for three genes and some patients harbour variants in two of these: COL1A1 & COL1A2. I had previously entered details of the pathogenic variant in COL1A1 for a patient and decided to enter details of a probably non-pathogenic variant in COL1A2. I clicked on \"Add new variant to patient\" and selected the COL1A2 gene. When I clicked on the \"Add variant data >>\" button the data-entry form was for COL1A2 but the showmaxdbid module was reporting the highest value in use for COL1A1, not COL1A2. I worked around this by entering COL1A2_00000 before saving the variant. When I later edited the variant, showmaxdbid did correctly show the values for COL1A2 and I was able to replace COL1A2_00000 with COL1A2_00131, the next available ID.
This task depends upon

Closed by  Ivo F.A.C. Fokkema (ifokkema)
Monday, 01 December 2008, 10:19 GMT+2
Reason for closing:  Fixed
Comment by Ivo F.A.C. Fokkema (ifokkema) - Monday, 14 April 2008, 12:09 GMT+2
Thank you for your bug report. This behavior has been confirmed. The calculation of the maximum DBID in use checks the current gene the user is working in, which could be different from the gene selected for the submission. This will be fixed in the next release.
Comment by Ivo F.A.C. Fokkema (ifokkema) - Friday, 08 August 2008, 15:21 GMT+2
Re-opened, still seems to be present under certain (unknown) circumstances.

Loading...