LOVD 2.0

Welcome to the LOVD 2.0 bug tracking system. Please note that this bug tracking system is not for LOVD 3.0!

If you have any issues, please read the documentation and Frequently Asked Questions.
Please note that you need to register before you can submit bugs or feature requests.

Information By default, all closed tasks are hidden from view.
Click here to see all tasks.


FS#36 - LOVD documentation does not work when LOVD is installed at /

Attached to Project: LOVD 2.0
Opened by Ivo F.A.C. Fokkema (ifokkema) - Monday, 06 October 2008, 11:17 GMT+1
Last edited by Ivo F.A.C. Fokkema (ifokkema) - Tuesday, 21 October 2008, 12:42 GMT+1
Task Type Bug Report
Category Documentation
Status Closed
Assigned To Ivo F.A.C. Fokkema (ifokkema)
Operating System All
Severity Medium
Priority Normal
Reported Version 2.0-12
Due in Version 2.0-13
Due Date 2008-10-31
Percent Complete 100%
Votes 0
Private No


The LOVD documentation tab malfunctions when LOVD is installed in the webserver root. The first preliminary results suggest that somehow the PHP thread crashes. It seems that sometimes level 2 documentation pages (pages one level below the documentation main chapters) are not affected. In other installations, level 3 documentation pages are not affected.
This problem has been confirmed on Linux and Windows hosts, using Apache 2.2.X and PHP 5.2.X.
This task depends upon

Closed by  Ivo F.A.C. Fokkema (ifokkema)
Friday, 31 October 2008, 18:00 GMT+1
Reason for closing:  Fixed
Comment by Ivo F.A.C. Fokkema (ifokkema) - Friday, 17 October 2008, 13:57 GMT+1
This seems to be caused by a infinite loop in the LOVD PHP function lovd_cleanDirName, when given the arguments like \"/docs/../../docs/index.php\". We are working on a fix.