LOVD 2.0

Welcome to the LOVD 2.0 bug tracking system. Please note that this bug tracking system is not for LOVD 3.0!

If you have any issues, please read the documentation and Frequently Asked Questions.
Please note that you need to register before you can submit bugs or feature requests.

Information By default, all closed tasks are hidden from view.
Click here to see all tasks.

Tasklist

FS#40 - Adding variants in different genes to a patient

Attached to Project: LOVD 2.0
Opened by Raymond Dalgleish (rwmd) - Friday, 13 February 2009, 15:08 GMT+2
Last edited by Ivo F.A.C. Fokkema (ifokkema) - Monday, 26 September 2011, 12:57 GMT+2
Task Type Feature Request
Category Backend / Core → Variant submission
Status Closed
Assigned To Ivo F.A.C. Fokkema (ifokkema)
Operating System All
Severity Medium
Priority Normal
Reported Version 2.0-14
Due in Version 3.0-beta-01
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It is awkward to create a patient record with variants in different genes. Creating the record for the first variant is straightforward. If you then try to create a second variant immediately, LOVD assumes that the variant must be in the same gene. Their is no obvious way to select another gene before the patient details are entered. The workaround is to only enter the one variant for the pateint and then to finalize the submission. Once that\'s done, you can change the gene and create the variant entry in that gene. When that\'s complete you can then attempt to use the \"Using an existing patient\" button. The problem is that you then get prompted to enter the ID for that patient and there is no way to look it up. You have to have written it down (or have a photographic memory).

The ideal solution would be the ability to change gene, as necessary, for each additional variant to be recorded for a patient. Alternatively, there should be the ability to look-up the patient.
This task depends upon

Closed by  Ivo F.A.C. Fokkema (ifokkema)
Monday, 26 September 2011, 12:57 GMT+2
Reason for closing:  Implemented
Additional comments about closing:  Implemented in LOVD 3.0-alpha-04.
Comment by Ivo F.A.C. Fokkema (ifokkema) - Friday, 13 February 2009, 15:34 GMT+2
The submission process works only on one gene at a time. From the manual:
\"If you want to add variant data from a different gene, first complete this submission and then add those other variants to your patient entry in a new submission process.\"

To get the patient ID of your patient, simply search for your patient and copy the number, shown in the detailed view (directly in the header).
But really much easier is to simply click the button \"Add new variant to patient\" below the patient information. That way, you don\'t even need to remember or copy any number but you can just use the submission process to add the new variant.
Comment by Ivo F.A.C. Fokkema (ifokkema) - Tuesday, 24 February 2009, 09:02 GMT+2
Since the submission process will change in 3.0, it will be easier in this release to submit variants in several genes all at once.

Loading...