LOVD 2.0

Welcome to the LOVD 2.0 bug tracking system. Please note that this bug tracking system is not for LOVD 3.0!

If you have any issues, please read the documentation and Frequently Asked Questions.
Please note that you need to register before you can submit bugs or feature requests.

Information By default, all closed tasks are hidden from view.
Click here to see all tasks.

Tasklist

FS#44 - Reference Sequence Parser 2.8 cannot overwrite old files

Attached to Project: LOVD 2.0
Opened by Raymond Dalgleish (rwmd) - Monday, 28 September 2009, 12:04 GMT+2
Last edited by Ivo F.A.C. Fokkema (ifokkema) - Tuesday, 29 September 2009, 13:39 GMT+2
Task Type Bug Report
Category Scripts
Status Closed
Assigned To Ivo F.A.C. Fokkema (ifokkema)
Operating System Linux / Unix
Severity Medium
Priority Normal
Reported Version 2.0-21
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Back in June, a bug was discovered in the "Reference Sequence Parser" script and it was subsequently fixed. The script had produced the expected output files but the data were incorrectly formatted. Today, I used Reference Sequence Parser again (for the first time since June) for the same gene as before and many error messages were generated this time.

I had selected the option of "overwrite it" to allow the old files to be overwritten if they existed, but the script was unable to do so because the permissions on the files (-rw-r--r--) did not allow it. Deleting each of the old files did then allow the script to create the new files.

Perhaps the script should create the files with the permissions -rw-rw-rw- to allow old files to be overwritten.
This task depends upon

Closed by  Ivo F.A.C. Fokkema (ifokkema)
Tuesday, 29 September 2009, 13:39 GMT+2
Reason for closing:  Not a bug
Comment by Ivo F.A.C. Fokkema (ifokkema) - Monday, 28 September 2009, 12:08 GMT+2
The rw-r--r-- permission should always be enough to overwrite the files created by the same user. Do you still have some of the error messages that you got on your screen? Or could you still verify if the current webserver user (i.e. www-data, apache) is the same as the webserver user in June?
Comment by Raymond Dalgleish (rwmd) - Monday, 28 September 2009, 12:22 GMT+2
It's the same web server as in June.

Unfortunately, I do not have the error messages and re-running the script does not now result in any errors. However, the fact remains that the script did not run without errors until I had manually deleted the old files.

Comment by Ivo F.A.C. Fokkema (ifokkema) - Tuesday, 29 September 2009, 13:39 GMT+2
Sorry, but I can also not reproduce the error. Because the rw-r--r-- permissions are correct, and we have no error messages to start with, I'm afraid I can't do anything right now. I will close this bug now, but feel free to reopen it if it happens again. If that is the case, please send us all of the error messages and verify the name of the webserver user and the owner of the files previously created.

Loading...