LOVD 2.0

Welcome to the LOVD 2.0 bug tracking system. Please note that this bug tracking system is not for LOVD 3.0!

If you have any issues, please read the documentation and Frequently Asked Questions.
Please note that you need to register before you can submit bugs or feature requests.

Information By default, all closed tasks are hidden from view.
Click here to see all tasks.

Tasklist

FS#45 - Bug with Firefox/Camino (Gecko engine) at login

Attached to Project: LOVD 2.0
Opened by Maxime Vallée (Max) - Monday, 26 October 2009, 11:05 GMT+2
Last edited by Ivo F.A.C. Fokkema (ifokkema) - Thursday, 07 January 2010, 14:34 GMT+2
Task Type Bug Report
Category Backend / Core → Setup area
Status Closed
Assigned To Ivo F.A.C. Fokkema (ifokkema)
Operating System All
Severity High
Priority Normal
Reported Version 2.0-22
Due in Version 2.0-23
Due Date 2009-11-02
Percent Complete 100%
Votes 0
Private No

Details

When login/password entered by an admin or a submitter using Firefox or Camino, it bounces back to the login page. Each time.

When Safari is used, it goes well.

Is my installation bad? Because I am pretty sure that your high quality tool works with free browsers world, so have you ever heard about that problem?
This task depends upon

Closed by  Ivo F.A.C. Fokkema (ifokkema)
Thursday, 07 January 2010, 14:34 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 2.0-23, released December 7th.
Comment by Ivo F.A.C. Fokkema (ifokkema) - Monday, 26 October 2009, 11:29 GMT+2
Hi,

Thanks for the bug submission. No, we haven't heard about this before. LOVD has not been tested with Camino, but I myself always use Firefox (Firefox/Linux and Firefox/Windows). So far, Firefox users on Mac have never reported this problem either.

If LOVD returns the login form again, does it also throw an error? Or does it only report an error when you type in a wrong password or username?

Does your browser accept cookies? If so, which cookies are present in your browser relating to this LOVD installation?
LOVD 2.0 does include a backup technique if cookies fail. If your LOVD installation is configured to use cookies only (see the system settings page at Setup area -> System settings -> scroll down to "Use cookies for user authentication"), does changing this setting have any effect on the problem?

Thank you for helping us improve LOVD.
Comment by Ivo F.A.C. Fokkema (ifokkema) - Thursday, 29 October 2009, 10:03 GMT+2
This problem seems to exist only on one server, running PHP 4.3.4. There are no other LOVDs running this version, to verify. On a server with 4.3.10 it works fine. The problem exists only in a few browsers and has to do with the way cookies are handled. I'm fixing this bug by excluding the Session Fixation security code for PHP versions below 4.3.10.

Loading...